Welcome, Guest. Please login or register.
October 24, 2014, 03:31:55 AM
Home Search Search Login Register

+  Pet Goldfish - Aquarium Forum Community
|-+  Aquarium
| |-+  General Goldfish Discussion
| | |-+  My filter is broken!
« previous next »
Pages: [1]
Author Topic: My filter is broken!  (Read 584 times)
jordon.chynna
Newbie
*

Karma: 2
Posts: 35


My filter is broken!
« on: February 20, 2012, 04:39:22 PM »

My undergravel filter flow has slowed right down. It's a resun dm-800 120 litre with the UGF built in. The gravel is regularly cleaned and the filter plates at the bottom of the tank were taken out and cleaned not two months ago. It's barely even trickling when it should be a proper flow. It's not airstone powered the water is pulled up by a grey box that must contain motor and then sent through the filter box via a power head. The water then comes back down into the tank through the other side.
Logged
cheri_alexander
Full Member
***

Karma: 56
Posts: 524



Re: My filter is broken!
« Reply #1 on: February 20, 2012, 05:03:10 PM »

Scratch the UGF and get a canister filter. Whatever you decide to do you need to fix the problem ASAP, your tank is too overstocked to go unfiltered even for a short time. I don't know anything about UGFs but maybe cleaning it would help?
Logged
Nossie
Hero Member
*****

Karma: 481
Posts: 5469



Re: My filter is broken!
« Reply #2 on: February 22, 2012, 04:46:44 AM »

It may be clogged or something, you know, small gravel fragments may have filled the holes in the plate. Either way, just get it exchanged, throw it out and never think about using a UG filter again. They really aren't suitable for goldfish and won't do anything but collect more dirt in the gravel than necessary. They were pretty common at one point, but should really be avoided in my opinion Smiley
Logged
Pages: [1]  
« previous next »
Jump to:  
Page created in 0.214 seconds with 17 queries.